Finanzkasper.de » Board

DE Ariva Rohstoffe - Gold

Hallo,

seit Anfang dieser Woche funktioniert die Abfrage nach Gold nicht mehr. Kennt jemand die Ursache (und kann einen Tipp zur Abhilfe geben)?

- Wilfried

quasimodoz
quasimodoz
Mitglied seit 11. 06. 2009
59 Beiträge

Offensichtlich gabs eine Formatänderung der Webseite.

Ich habe die Serverdefinition angepasst. Nach dem nächsten Neustart von QC funktioniert es wieder.

zerus

zerus
zerus
Mitglied seit 22. 07. 2007
1925 Beiträge

[quote="zerus"]
Offensichtlich gabs eine Formatänderung der Webseite.

Ich habe die Serverdefinition angepasst. Nach dem nächsten Neustart von QC funktioniert es wieder.

zerus
[/quote]

Alles klappt wieder wunderbar. Vielen Dank zerus!

- Wilfried

P.S. Wo könnte ich lernen wie das geht um es auch mal selbst zu machen und nicht alle Arbeit nur abzuschieben?

quasimodoz
quasimodoz
Mitglied seit 11. 06. 2009
59 Beiträge

[quote="quasimodoz"]
P.S. Wo könnte ich lernen wie das geht um es auch mal selbst zu machen und nicht alle Arbeit nur abzuschieben?
[/quote]

Es gibt von mir keine Anleitung dazu.

Aber es ist sehr einfach:
Man muss einen gültige URL haben, also den Link zu einer Webseite mit dem interessierenden Kurs.
Diese ruft man auf und schaut sie sich an.
Dazu schaut man sich den Quelltext dieser Seite an (HTML).

Im Quelltext sucht man nun nach dem Kurs, wie man ihn auf der Webseite sieht.

Jetzt sucht man sich Suchbegriffe kurz vor dem Kurswert im Quelltext.
QC kann nacheinander bis zu 4 Strings suchen, um möglichst nah und genau an den Kurs zu kommen. Danach kann man zur Eingrenzung noch sagen wie viele HTML Tags ("<>", in spitzen Klammmern) noch bis zum Kurs kommen; oder wie viele Zahlen noch bis zum Kurs kommen.

Es geht immer darum, möglichst genau an den Anfang des Kurswertes zu kommen.
Das Ende des Kurswertes erkennt QC automatisch.

Alles was ich eben zum Kurs geschrieben haben, gilt auch für das Kursdatum, die Kurszeit etc.

Vielleicht schreibt mal jemand, der weiss wie es funktioniert, es etwas detaillierter auf und postet eine Anleitung.

Gern beantworte ich auch Fragen dazu hier.

Es ist nicht schwer....

zerus

zerus
zerus
Mitglied seit 22. 07. 2007
1925 Beiträge

Seit geraumer Zeit funktioniert der $-Goldpreis nicht mehr. Ich habe mal versucht die Serverdefinition anzupassen. Leider ohne Erfolg. Was mache ich wohl falsch?

WKN: 965515
Serverdefinition: URL = http://www.ariva.de/goldpreis-gold-kurs?utp=1
Kurs - Suchtext 1: schema.org/offer
HTML: 1

Einstellungen: Tausender .
Dezimalpunkt ,
Häkchen "Entferne HTML-Smbole: mit und ohne versucht

quasimodoz
quasimodoz
Mitglied seit 11. 06. 2009
59 Beiträge

Seit geraumer Zeit funktioniert der $-Goldpreis nicht mehr. Ich habe mal versucht die Serverdefinition anzupassen. Leider ohne Erfolg. Was mache ich wohl falsch?

WKN: 965515
Serverdefinition: URL = http://www.ariva.de/goldpreis-gold-kurs?utp=1
Kurs - Suchtext 1: schema.org/offer
HTML: 1

Einstellungen: Tausender .
Dezimalpunkt ,
Häkchen "Entferne HTML-Smbole: mit und ohne versucht

quasimodoz
quasimodoz
Mitglied seit 11. 06. 2009
59 Beiträge

Ja, es gab offensichtlich Änderungen an der Webseite.
Hier meine Kommentare:

1.
Ich habe aufgrund deines Postings die Serverdefinition angepasst. Es sollte nach dem nächsten Start von QC nun mit dem Server wieder funktionieren wie früher.

2.
Ich selbst nutze für Gold in $ den Server "DE Ino Devisen" wobei man als WKN XAUUSDO eintragen muss.

3.
Weiss nicht genau woran es liegt, dass deine Serverdefinition nicht funktioniert. Eigentlich müsste sie, es sieht alles richtig aus. Eventuell gibt's ein Problem mit den Sonderzeichen wie Punkt oder Schrägstrich. Habe jetzt nicht tiefer im Code recherchiert. Was aber geht mit dieser URL ist folgendes:
Suchtext1: price
Suchtext2: content=
HTML: 0
Tausender: ,
Dezimalpunkt: .

zerus

zerus
zerus
Mitglied seit 22. 07. 2007
1925 Beiträge

Vielen Dank Zerus,

ich habe für ein anderes Produkt noch ein Problem und einen Vorschlag für eine kleine Änderung am Programm, falls dadurch nicht andere Serverdefinitionen unbrauchbar werden.

Mein Problem ist die Suche. Ich suche aus einer Tabelle einen Wert aus der zweiten Tabellenspalte. Dafür reichen die Anzahl der Suchkriterien nicht mehr aus. In den Suchkritereien kann ich zwar die Anzahl der <>Tags angeben und die Anzahl der Zahlen, das Problem ist aber, das ZAHLEN und nicht ZIFFERN gesucht werden und ein dd.mm.jjjj Datum als eine Zahl interpretiert werden. Deshalb kann ich, wenn die Suche nach "." aufgebraucht ist, z.B. nicht mehr den Moant oder das Jahr extrahieren. Vielleicht lässt sich das irgendwie im Programm ändern.

Außerdem hätte ich den Vorschlag, das entweder der Zeitwert nicht mehr eingegeben werden muss oder dort $NULL für 00:00:00 Uhr eingetragen werden kann. Denn für historische Daten (z.B.von gestern) interessieren die Uhrzeit-Werte eigentlich gar nicht, sondern nur das Datum.

Gruß,

Wilfried

quasimodoz
quasimodoz
Mitglied seit 11. 06. 2009
59 Beiträge

[quote="quasimodoz"]
Mein Problem ist die Suche. Ich suche aus einer Tabelle einen Wert aus der zweiten Tabellenspalte. Dafür reichen die Anzahl der Suchkriterien nicht mehr aus. In den Suchkritereien kann ich zwar die Anzahl der <>Tags angeben und die Anzahl der Zahlen, das Problem ist aber, das ZAHLEN und nicht ZIFFERN gesucht werden und ein dd.mm.jjjj Datum als eine Zahl interpretiert werden. Deshalb kann ich, wenn die Suche nach "." aufgebraucht ist, z.B. nicht mehr den Moant oder das Jahr extrahieren. Vielleicht lässt sich das irgendwie im Programm ändern.
[/quote]
Ich kenne das Problem, kommt selten mal vor, dass man da nicht weiterkommt.
Bevor ich das Programm erweitere: kannst du mir bitte mal die Details nennen, also Wertpapier und URL. Erstens könnt ich versuchen, es so hinzubekommen. Und wenn das nicht klappt, könnte ich an diesem Beispiel den Programmcode erweitern.

[quote="quasimodoz"]
Außerdem hätte ich den Vorschlag, das entweder der Zeitwert nicht mehr eingegeben werden muss oder dort $NULL für 00:00:00 Uhr eingetragen werden kann. Denn für historische Daten (z.B.von gestern) interessieren die Uhrzeit-Werte eigentlich gar nicht, sondern nur das Datum.
[/quote]
Du kannst bereits jetzt ein Datum eintragen und den Zeitwert einfach leer lassen. QC setzt als Zeit dann automatisch 20:01 ein. Das schien mir mal plausibler, da es eher einem Tagesschlusskurs nahe kommt als 00:00 Uhr.

zerus
zerus
Mitglied seit 22. 07. 2007
1925 Beiträge

Hallo Zwerus,

[quote="zerus"]
Ich kenne das Problem, kommt selten mal vor, dass man da nicht weiterkommt.
Bevor ich das Programm erweitere: kannst du mir bitte mal die Details nennen, also Wertpapier und URL. Erstens könnt ich versuchen, es so hinzubekommen. Und wenn das nicht klappt, könnte ich an diesem Beispiel den Programmcode erweitern. [/quote]

Ich schicke mal eine Serverdefinition für "BitCoinUSD" mit. In dieser Definition kann ich leider nicht das Jahr für den historischen Wert extrahieren. Stattdessen habe ich das Jahr vom aktuellen Tag extrahiert.

[quote="zerus"]
Du kannst bereits jetzt ein Datum eintragen und den Zeitwert einfach leer lassen. QC setzt als Zeit dann automatisch 20:01 ein. Das schien mir mal plausibler, da es eher einem Tagesschlusskurs nahe kommt als 00:00 Uhr.
[/quote]

Das klappt prima. Danke!

Noch etwas. Beim Rumspielen ist mir aufgefallen, dass ich die bestehenden Serverdefinitionen nicht löschen kann. Wenn ich dann Serverdefinitionen importiere, werden sie einfach drangehängt. Gibt es irgendwo die Möglichkeit nur die Servedefinitionen komplett zu löschen?

Hintergrund ist, dass ich mir eine Definition zerschossen habe. Die musste ich mir dann aus einen kompletten Backup herausziehen und Zeichen für Zeichen neu eingeben.

Gruß

quasimodoz
quasimodoz
Mitglied seit 11. 06. 2009
59 Beiträge

0 Mitglieder Online

Keine Mitglieder Online

Letzte Änderung dieser Seite: 05.09.2020 10:18:28  --- (c) FinanzKasper.de ---     Home :: Suche :: Sitemap :: Impressum :: AGBs :: Datenschutz